
        
 

  

 
            

            
                

     

             
               

                
               

       

             
 

      
               

          

            
                

               

        

         
 

     
        

 
      

      

Plo%ng UHIP Data with QGIS 

Overview 
In this exercise, we will take a dataset collected with an AREN TerraROVER and UHIP and import 
it into QGIS. QGIS is a powerful Geographic InformaGon System (GIS) applicaGon that allows you 
to process and analyze spaGal datasets on their own, and in relaGon to other spaGal datasets 
through the use of layers. 

The UHIP has an onboard GPS receiver, which provides spaGal coordinates (LaGtude and 
Longitude) for each point in the dataset. This will enable QGIS to plot the data on a map. Once 
our data is ploOed, we will symbolize it in a way that represents the range of values in the data. 
We will then overlay it on aerial imagery so that we can explore the relaGonship between the 
data and the surface features where it was collected. 

If necessary, please download and install the latest “stable” QGIS soSware from this link: 
hOps://www.qgis.org/en/site/forusers/download.html. 

Part One: Prepare your data. 
The data from the UHIP is a text-based .CSV file. In order to use it with a Geographic InformaGon 
System like QGIS, you must make a small change to the file. 

Open your file using a spreadsheet program such as MicrosoS Excel, Google Sheets, Apple 
Numbers, or Libre Office Calc. Once the file is open, save it as a Comma Separated Values (CSV) 
file with a new name. (Ignore any workbook warnings when saving this file type in Excel.) 

You will use this new file with QGIS. 

Part Two: Launch QGIS, start a new project, set the CRS, 
and load a basemap. 
1. Launch the QGIS ApplicaGon 
2. When it loads, open the Project menu and select New. 

Figure 1 – Start a new Project 

A new blank Project window appears (Figure 2). 
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Figure 2 – New Project Window 

Cartographers use coordinate systems in order to map data to the surface of the Earth. 
Geographic coordinate systems are used to plot x, y coordinates on the surface of the Earth. 
Projected coordinates determine how those locaGons will be projected onto a flat surface 
(map). 

Because the Earth is roughly a spheroid (or more accurately, a geoid that is not evenly 
smooth), there are many different coordinate systems in use to accurately map data on local 
or global scales. We want to make sure that the coordinate systems we use work with our 
data. Before we add layers, we will set the map environment up so that the coordinate 
systems we use plot our data correctly. 

3. Click the Sedngs tab in the top menu, and select OpGons 

Figure 3 – Open the Op;ons window 

The opGons window will open. 
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4. Click the down arrow next to CRS and Transforms in the leS panel, and select CRS Handling 

5. In the CRS Handling Window, set the opGons as they appear in Figure 4. 

a. Under CRS for Projects, check the Use CRS from the first layer added opGon 

b. Under CRS for Layers, the Default CRS for Layers should be EPSG:4326 – WGS 84, and 
Use default layer CRS should be checked 

c. Click OK 

Figure 4 – Se>ng the Coordinate Reference System (CRS) defaults 

Your coordinate reference systems should be set correctly. 

6. Add a basemap. 

a. In the browser window, click the down arrow next to XYZ Tiles. You should see a list of 
XYZ basemap Gles. 

b. Drag the Open Street Map Gle from the Browser window into the Layers window to load 
it in the project window. The map will update, and OpenStreetMap will appear in the 
Layers window. 
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Figure 5 – Load a Basemap 

The OpenStreetMap basemap now appears in the project window. 

Part Three: Add your CSV file to the map as a layer. 
One of the most powerful features in a GIS is the ability to add layers to a map. Layers can 
include many different types of spaGal data, and analysis tools can be used to find relaGonships 
between data in different layers and even create new data layers from exisGng ones. 

The two primary types of data layers used in a GIS are Vector and Raster. 

A vector layer is composed of points, lines, or polygons. These are mathemaGcal construcGons 
that contain spaGal informaGon. Examples of vector datasets include address locaGons 
represented as points, roads or rivers represented by lines, and building footprints or property 
boundaries represented by polygons. The locaGon and shape data for vector datasets are 
contained in their aOribute tables. There can be many other aOributes associated with the 
vector features stored in the aOribute table as well. (This is the data in your CSV file.) 

Raster datasets represent conGnuous features like terrain or aerial imagery. Rasters are arrays of 
data, oSen in pixel format, where individual pixels contain values that can be analyzed and 
manipulated. 

In this example, we are going to add our UHIP CSV data to the map. The UHIP data contains 
longitude and laGtude informaGon for each point, which was obtained by the GPS receiver on 
the UHIP instrument. 

Start by finding the approximate locaGon where your data was collected. If you know the 
locaGon name or address, you can type it into the search box in the lower leS of the project 
window. 
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7. Find the Type to locate search field in the boOom leS corner of your project window. Click 
on the Search icon to be sure the NominaFm Geocoder is selected. The geocoder is a tool 
that searches the map for address locaGons. (Figures 6 and 7) 

Figure 6 – Search field and icon Figure 7 – Select the Geocoder 

8. ASer you select the geocoder, type the address into the field and select it from the list of 
candidates that appears. 

The map should jump to the address locaGon. You will probably need to adjust the locaGon 
somewhat. To center the map over your target area, use your scroll wheel to zoom in and 
out, and hold down on your leS mouse buOon and drag to pan or move around the map. 

Figure 8 – Enter address and map jumps to loca;on 
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Now we will proceed to add our UHIP data. UHIP data is in CSV (Comma Separated Values) 
format. This is a type of delimited text file, in which the aOributes are separated by a 
delimiter (in this case, a comma). We will import the file as a Delimited Text Layer. The 
soSware will use the Longitude and LaGtude aOributes in the file to create a point feature 
vector layer in the map. 

9. Select Layer > Add Layer > Delimited Text Layer from the top menu. (Figure 9) 

Figure 9 – Add Delimited Text Layer 

The Data Source Manager window opens 

10. Confirm that Delimited Text is selected in the leS panel, then click on the ellipsis (•••) 
buOon in the upper right to navigate to your UHIP data file (Figure 10) 

Figure 10 – Data Source Manage | Delimited Text 

11. In the pop-up window, navigate to your saved UHIP CSV file. Select the file and click Open 
(Figure 11). 
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Figure 11 – File Naviga;on window 

The Data Source Manager | Delimited Text window will update. 

12. Examine the window and ensure the following parameters are set (as seen in Figure 12). 

a. The path and imported file name are listed under File Name 

b. The File Format is CSV (Comma Separated Values) 

c. Click the arrow next to Geometry DefiniFon (if it is not open). 

d. The Point Coordinates should be checked 

e. The X field should be Longitude 

f. The Y field should be LaFtude 

g. The Geometry CRS should be EPSG:4326 - WGS 84 

h. You should see a sample of your data in the Sample Data window. 

Figure 12 – Data Source Manage | Delimited Text se>ngs 
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13. When the sedngs look correct, click Add 

14. Close the Data Source Manager window 

A new data layer will appear in the Layers window, and the data points will appear in the map 
window. 

Figure 13 – UHIP data added to the map 

15. Right-click on the layer name in the Layers panel and select Zoom to Layer(s). 

Figure 14 – Zoom to your UHIP layer 

Your data layer is now centered in the window. Let’s take a closer look at the data. 

Part Four: Explore your data. 
16. Locate the IdenFfy Features buOon in the menu bar and select it. (Figure 15) 
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Figure 15 – Select the Iden;fy Features tool 

17. Click on a data point in the map 

A panel will open on the side and display the aOribute data associated with that point. 
(Figure 16). Examine the values in the fields. Try clicking on a few others. Closes the panel 
when you are finished. 

Figure 16 – A]ribute data for a point 

18. To see all of your aOribute data in table format, click the Open AXribute Table buOon 

Figure 17 – Open A]ribute Table bu]on 

A table will appear with all of your aOributes (Figure 18). This should look familiar – much 
like viewing your data in a spreadsheet. 
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Figure 18 – A]ribute Table 

There are several tools in the aOribute table header. For now, we will work with the 
Filter/Select tool to find the hoOest surface temperatures in our data. 

If we scroll through this aOribute data, we will see that the values in the IR_Temp field (the 
surface temperature field) range from 17.47ºC to 42.25ºC. We would like to see where the 
hoOest values are on the map – say everything over 40ºC. 

19. Click on the Select/filter features buOon in the aOributes table menu (Figure 18). 

Figure 19 – Select/filter features bu]on 

The table changes to a form. 

20. Enter “40” into the IR_Temp Field, then click the “Exclude Field” buOon to the right of the 
IR_Temp field and select the “Greater than (>)” opGon from the dropdown. (Figure 20) 

Figure 20 – Filter form with Greater than (>) selected for IR_Temp field 
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21. Click the Select Features buOon in the lower right of the window and choose Select 
Features from the dropdown menu. 

Figure 21 – Select Features bu]on and dropdown 

Your map will now highlight in yellow all the points where the measured surface 
temperature (IR_Temp) is over 40ºC. (Figure 22) You may need to move the form window to 
see all of your data points. 

Figure 22 – Selected data points with surface temps over 40º 

You can build simple or complex filters to quickly explore many aspects of your data. This is 
just a quick example. 

22. Click the Deselect all features buOon. 

Figure 23 – Deselect data points 
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23. Close the aOribute table/form window 

Part Five: Add a satellite imagery basemap and symbolize 
your data to reflect an aLribute. 
The TerraROVER UHIP collects data from the surface features you drive over and the 
atmosphere directly above them. Our data is currently ploOed over a street map, which does a 
good job of showing the locaGon of the data, but it would be more meaningful if we could see 
the actual surface features over which we collected the data. Then we could begin to make 
inferences about the relaGonship between surface feature types and our measurements. 

We will add a layer of satellite imagery as a basemap. 

24. Click the HCMGIS tab in the menu bar, and select Basemaps > Bing Virtual Earth. You could 
also select Google Satellite or Esri Satellite Imagery from the dropdown if you prefer. If the 
HDGMIS tab is not available, follow the steps in the Appendix (page 18) to acFvate it. 

Figure 24 – Add Basemap from HCMGIS menu 

Bing Virtual Earth appears in the Layers Menu and in your map window. (Figure 24) 

Figure 25 – Bing Virtual Earth added to Layers 
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When you add a new layer in QGIS, it appears at the top of the layers list by default. 
Unfortunately, it is covering up our UHIP data layer. We will reorder layers in the Layer menu 
to expose our data. 

25. Use your mouse to grab the UHIP data layer in the Layers menu and drag it to the top of the 
list. Uncheck the OpenStreetMap layer as well. (Figure 26.) 

Figure 26 – Reorder layers 

The UHIP data now appears above the satellite imagery. 

Figure 27 – UHIP data on top of satellite imagery 

We can now see our data points overlain on imagery of the surface feature. Next, we will 
symbolize our data so that the data point colors represent an aOribute of the data. We will 
use a color ramp to symbolize the IR_Temp (surface temperature) aOribute. 
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26. Right-click on the layer name and select ProperFes from the dropdown 

Figure 28 – Open Layer Proper;es 

27. Click on Symbology on the leS panel of the Layer ProperFes dialogue window. 

Figure 29 – Open Layer Proper;es – click on Symbology 
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The Symbology panel opens. (Figure 30) 

Figure 30 – Symbology Panel 

Currently, all of the data is represented with a single symbol. We want the symbols to 
represent the range of our surface temperature data, so we will change this to graduated 
symbols and use a color ramp that bins the data into 5 equal interval classes from low to 
high. 

28. Make the following adjustment to the sedngs (refer to Figure 31 on the next page): 

a. Click on the "Single Symbol" dropdown and select "Graduated" from the list. 

b. Select a variable from the Value field (IR_Temp in our example). 

c. Make sure Method is set to “Color” 

d. Leave Symbol, Legend format, and Color ramp in their defaults for now. 

e. Click on "Mode" 

f. Select "Equal Interval". This creates categories, or classes, with equal intervals, which is 
useful for temperature data. 

g. Set Classes to 5. 

QGIS selects the high and low values and divides the range into 5 equal intervals. The 
UHIP data in this example has a range from about 17.5ºC to 42.5ºC for the IR_Temp 
field. This is a 25ºC range. If we use 5 classes, each class will span 5º. We could use 10 
classes, and each would span 2.5º for a higher degree of precision. We will use 5 for 
now. 
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h. Leave Link class boundaries checked 

i. Click the Classify buOon 

j. Click Apply to preview the changes 

k. When saGsfied, click OK 

Figure 31 – Symbology Panel se>ngs 

The UHIP Data now appears with symbology that represents temperature. (Figure 32). Can 
you detect any paOerns in how the surface temperature is distributed over land cover? Are 
there any surprises? 
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Figure 33 – Symbolized UHIP data 

You can go back into the symbology panel and try different sedngs to see how they affect 
your data display. There are many possibiliGes. Try looking at the Air Temp field instead of IR 
Temp. How is it similar or different? What might explain these paOerns? 
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Appendix: Adding Basemaps by Enabling the HCMGIS Plugin 

You can expand the capabiliGes of QGIS through the use of Plugins. These are add-on tools that 
have been developed to allow QGIS to do tasks that aren’t included in the base installaGon. We 
are going to enable and use the HCMGIS plugin to add basemaps to our map. 

1) Click Plugins in your menu bar and select “Manage and Install Plugins…” from the 
dropdown menu 

Appx. B: Fig. 1 – Select the Manage and Install Plugins window 

2) In the pop-up window, click on the Installed tab. 

Appx. B: Fig. 2 – Installed Plugins list 

If you see the HCMGIS plugin listed, make sure its box is checked, close the window and skip 
ahead to Step 7. 

3) If you do not see HCMGIS listed, click on the Not Installed tab. 

Appx. B: Fig. 3 – Not Installed Plugins list 

4) You will see a long list of plugins. To make finding ours easy, type HCMGIS into the search 
bar at the top of the window. 

Appx. B: Fig. 4 – Search for HCMGIS plugin 
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5) Now only the HCMGIS plugin appears. Select it, then click Install Plugin 

Appx. B: Fig. 5 – Install the HCMGIS plugin 

6) Click on the Installed plugins tab again, and you will see the HCMGIS plugin listed. Make 
sure it is checked, then click Close 

Appx. B: Fig. 6 – Confirm HCMGIS plugin is ac;ve then close window 

7) The HCMGIS plugin now appears in your menu bar. 

Appx. B: Fig. 7 – Locate HCMGIS plugin in menu bar 
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8) Click on HCMGIS. In the dropdown, select Basemaps, then choose one from the list. For this 
exercise, choose either Google Satellite or Bing Virtual Earth. 

Appx. B: Fig. 8 – Select a basemap from the plugin 

The newly added basemap will appear in your Layers menu and be displayed in the map 
window. 

Appx. B: Fig. 9 – New Basemap appears in the Layers menu 

Hint – you can add more than one to your map and toggle between them. You may find that 
at different scales, you prefer one over the other. 

Now that it is installed, the HCMGIS plugin is available from the menu bar anyGme you run 
QGIS. Just click on it and select the basemap you wish to use. 
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